0.9.23.065 (2nd patch release, 6th November 2019):

Added Features

  • Added an EXPLORE button to the Render Still dialog so users can open a Windows Explorer window on the destination image file.
  • Added support for re-syncing audio to the current play position as required. This is only done in Builder whilst playing.

Changes

  • Replaced the “Save” option in the Log Window with “Explore..”, which opens a Windows Explorer window on the log folder and selects the latest log file.
  • Improved error messages returned from NGX and OptiX libraries that we depend on.
  • Updated material parameters in the Property window so that if material refraction is disabled then so is the Refraction IOR parameter.
  • Improved performance of the video playback system.
  • If a sound resource fails to load then the resource is now marked as invalid.
  • Updated the Autosave Recovery dialog to show all the saves found, not just the first 16.
  • Updated perpetual licensing to handle portrait as well as landscape for resolution limits.
  • Worked around an issue on some AMD cards where enabling Deferred Rendering on the Root node would cause the application to crash.

Bug fixes

  • Fixed some runtime logging issues when using a Kinect2 device.
  • Fixed a bug editing the properties of child nodes from an Imported 3D Scene node.
  • Fixed a crash when using the Ctrl+I shortcut to paste from clipboard.
  • Fixed a bug which could cause a video to be corrupt during playback.
  • Fixed a crash bug in the Text node when using the Words To Clones option.
  • Fixed a bug which meant the camera pivot handle was visible in exported image sequences.
  • Fixed a bug updating the Status Bar, which resolves a performance issue.
  • Fixed a copy-paste bug when the copy selection includes a Root node. When pasting the node links would be broken.
  • Fixed a bug in the Skylight node where the AO mode did not respect the Omnidirectional setting.
  • Fixed a number of Deformer node memory leaks throughout.
  • Fixed a performance regression when using the FFT Texture Generator node.
  • Fixed a memory leak when using the Ctrl+I shortcut.

0.9.23.061 (1st patch release, 29th October 2019):

Changes

  • Updated the Substance Material node so that it no longer has a parent connection tab in the nodegraph.
  • Updated the Bake Lighting To Object node to pre-prime the destination filename for the lightmap based on previous bakes.
  • Updated Cut/Copy Node With Children to not allow the Root node to be cut or copied.
  • Renamed “Video Capture In Plugin” to “Video Capture In Exported Block” in the Project Settings dialog.
  • Moved the UnicodeSample.dfx project file from the additional Samples Pack download into the main installer for Notch.
  • Moved the Alembic Balls.dfx project from the main Notch installer, into the additional Samples Pack download.
  • Updated all material bins to include a connection point so users can connect the materials more easily (ie. without up-grouping).
  • Updated the status bar so it refreshes more frequently.
  • Changed Max Refine Steps default from 10000 to 1000 in the RT Refinement node.
  • Updated video export to try to prevent the system from sleeping whilst rendering video or stills.
  • Updated the “Open Containing Folder” option in the Resource Browser to also select the file in Windows Explorer.

Bug fixes

  • Fixed a bug in the Clone To Mesh node when the Spread Over Surface mode is selected. In this mode, clones could flicker per frame.
  • Fixed a bug when “Show timeline ruler in frames” is selected, which could cause the wrong frame number to be displayed.
  • Fixed a resource leak when using the Bake Lighting To Object node.
  • Fixed a bug in the video playback system which could cause rendering corruption.
  • Fixed a performance bug when Ray Tracing is enabled and cloner nodes have multiple parents in the nodegraph.
  • Fixed a bug which meant the refine counter in the status bar could show the wrong value.
  • Fixed a bug in the Bake Lighting To Object node which meant the filename for the baked lightmaps could not be overridden via the bake dialog.
  • Fixed a number of bugs in the Particle Geometry Connection Renderer node which could cause rendering corruption.
  • Fixed a bug in the Fields Fluid Affector node which meant it could be using invalid colour and motion vector render targets.
  • Fixed a bug when loading IES files.
  • Fixed a bug in the Sky Light which would cause D3D11 errors to be generated.
  • Fixed cropped text in the Export Video and Export Still dialogs.
  • Fixed a number of bugs relating to spatial transformations in the Slice Deformer node.
  • Fixed the Ray Tracing toolbar button so that you do not need to click on the Render Window to trigger a render update before seeing the changes.
  • Fixed a bug in the Extruded Spline node where vertex normals did not take varying radius into account.
  • Fixed a bug when zooming using an orthographic camera.
  • Fixed pressing End (and Ctrl+End, Shift+End) so it jumps to the last full-frame, not subframe.

0.9.23.059 (official release, 22nd October 2019):

Important

  • We have changed the internal time base for Notch projects to a higher granularity. This allows keys and time bars at all common frame rates (12, 15, 25, 30, 50, 60, 100 etc) to be represented accurately. Previously only 25 and 50 fps were able to be stored accurately.
    This is fully backwards-compatible: projects or bins saved in previous versions of Notch will load and convert to the new timebase without issue.
    But it is NOT forwards-compatible: projects saved from 0.9.23.059 will not load properly in older versions of Notch.
  • 32bit support is now deprecated in Builder, blocks & standalone. The vast majority of host applications / media servers support 64bit, but if yours doesn’t 0.9.22 (32bit) is still available for download.

Added Nodes

  • Ray Tracing
    • Pathtracer | Simulates lighting of solid objects accurately with support for multiple bounces of specular and diffuse reflections and refractions with varying roughness and other material attributes.
    • RT Ambient Occlusion | Simulates ambient occlusion for ray-traced scenes.
    • RT Diffuse Bounces | Simulates diffuse lighting of solid objects accurately with support for multiple bounces.
    • RT Multi-Bounce Reflection | Simulates specular lighting of solid objects accurately with support for multiple bounces.
    • RT Glass Refraction | A fast and cheap raytraced glass solution.
    • RT Refinement | Used to control refinement parameters throughout the scene.
  • Materials
    • Glass RT Material | Basic glass material, configured with parameters for representing raytraced glass.
    • Semi-Transparent RT Material | Basic semi-transparent material, configured with parameters for representing raytraced transparencies.
  • Deformers
    • Separate Faces Deformer | Separates the faces of a mesh into individual chunks so they can be transformed.
    • Extrude Faces Deformer | Extrudes the faces of a mesh and generates additional adjacent polygons to connect the extruded faces.
    • Slice Deformer | Cuts a mesh and generates slices which follow the contours of the original mesh.
  • Generators
    • Jigsaw | Generates a jigsaw pattern as a texture.
  • Lighting
    • Environment Image | Generates an environment image from an HDR/EXR image for use with a Skylight or other lighting nodes.
  • Nodes
    • Clock Time As Text | Outputs the current clock time as a string.
  • Post-FX
    • Blur->Glow 2 | Resolution independent glow.
  • Video Processing
    • Input Output->Video Clip | Can be used to play multiple videos, split by time segments, from one single node.
    • Image Processing->AI Upscale | Upscales an image using AI to produce an image larger in size without paying the cost to render it.

Renamed Nodes

  • Ray Tracing
    • The RT Denoiser node has been renamed to RT Real-Time Denoiser.

Added Shortcuts

  • Ctrl+R toggles ray tracing on the Root node.
  • Ctrl+Shift+R toggles scene refinement.
  • Ctrl+Shift+E moves text entry to the Property window search box.
  • Ctrl+5 focuses on the selected object and switches to the orbit camera view.
  • Shift+F8 opens the Render Still dialog.
  • B sets the Range start time when in the Timeline window.
  • N sets the Range end time when in the Timeline window.
  • Alt+` toggles displaying the Notch UI in VR.

Added Features

  • Added fully integrated Path Tracer: Read about it in our manual and on our blog
  • Added two additional denoisers: NVIDIAs OptiX™ RTX powered GPU denoiser and the Intel® OIDN high-quality CPU denoiser
  • Added NVIDIA RTX™ powered AI image upscaler.
  • Added 7 new samples. Please see the Samples tab in the Notch Builder Project splash. Lemon Ice, Infinity Illusion Mirror, Bent Toruses, Cherry Dew, Fields in a Box, Particle Simulation w Procedural Meshing, Pathtracer Simple Sample. For larger samples, please see: here.
  • Added a new and highly performant video prefetching system. This results in a much more efficient video playback system including support for playing back the same video file with different time offsets.
  • Added Key & Fill output to standalone, for use with external vision mixers.
  • Added Grid and Settings options to the Viewport Guides toolbar button. Useful for overlays.
  • Added a Notch Assistant popup window to help users. See the Enable Notch Assistant Popups option in the File->Preferences dialog.
  • Added ‘Render Still’ support that allows you to render a single still frame with options for quality and resolution. Shortcut Shift+F8.
  • Added new blend modes to Post FX: Difference, Exclusion, Dodge, Burn, Negate and Overlay.
  • Added a Turbo button to the export video progress dialog. This reduces the time taken to render a video but may cause other applications on your system to run slowly or become unresponsive.
  • Added a command-line option (+monitor) to standalone applications to allow the user to specify the output head to use.
  • Added a command-line option (+keyandfill) for standalone applications.
  • Added a viewport panning button to the render window.
  • Added new and more accurate lighting model for Area Light nodes (LTC).
  • Improved the performance of geometry deformer nodes.
  • Improved the performance of Notch Builder when moving nodes in the Nodegraph.
  • Improved the performance of non-shadowed lights throughout.
  • Improved the responsiveness of Notch Builder when rendering video.
  • Added node presets for Particle nodes, RT Refinement and Glow 2.
  • Added new Lighting bins.
  • Added a Clamp Source Colour checkbox parameter to the Recolour Post FX node.
  • Added the default key interpolation type to the registry and read it when Notch is started. Defaults to TCB as before.
  • Added a timer to the status bar to show when your project was last autosaved.
  • Added a Distance To Scale, Min Distance and Max Distance parameters to the Procedural Emitter Particle node.
  • Added support to the Procedural Emitter Particle node for culling particles that overlap in the procedural volume.
  • Added support to the Procedural Emitter Particle node for using procedural colours as well as setting a min and max scale.
  • Added support for dragging multiple layers in the Timeline when using Shift.
  • Added support for handling the Flat Shade Colours checkbox in the Material node when ray tracing.
  • Added support for object space normal maps when ray tracing.
  • Added an Emissiveness view to the viewport rendering options.
  • Added a NotchLC transcode quality dropdown menu to File->Preferences. This quality is used for all videos that need transcoding on import. Defaults to Optimal.
  • Added support for selecting keys in the keyframe Curve editor window using Ctrl and select.
  • Added a pause button to the export video dialog.
  • Added support for snapping mouse input positions to the render window grid. Useful for the Curve Mask node.
  • Added an Export To OBJ right-click context menu option to the Procedural Meshing node.
  • Added a Check For License Updates button to Notch License Check.
  • Added support for transport controls in exported VR applications. Space = Pause, Home = Return to Beginning, Up/Down = Move between layers.
  • Added support for colour channels to the CSV Transform Array node.
  • Added total refinement steps Notch will perform for the scene to the status bar. Also added an elapsed time for the refinement.
  • Added support for visualising the skydome in the Sky Light node.
  • Added an option to the Skylight node to lock the new visualised skydome to the camera.
  • Added an Update Dongle Firmware button to Notch License Check.
  • Added draggable corner handles to the Image 2D node.
  • Added rulers around the render window. These can be toggled via the Show Render Window Ruler option in the View menu.
  • Added support for translucent shadows to the Skylight node.
  • Added a Font Size parameter to the Comment and Region nodes.
  • Significantly improved the performance of Cloners in ray-traced scenes.
  • Added a Diffuse Coat parameter to Material nodes for defining a flat colour applied only to transparent materials.
  • Added support to Area Light nodes so their geometry can now cast shadows.
  • Significantly improved the performance and accuracy of the object bounds generator.
  • Added the TdrDelay and TdrDdiDelay values from the registry to the File->Preferences dialog.
  • Added support for instancing of letters and words to clones in the Text node.
  • Improved performance when Skybox nodes are added to ray-traced scenes.
  • Added Artnet support to the Connection Monitor window.
  • Added support for Render Z Only and Render To Shadows Only parameters to the Text node.
  • Added support for inserting nodes at the current time. This is controlled by the Insert Nodes At Cursor Time tick box in Preferences (disabled by default).
  • Added support for rendering timeline markers to the Ruler. Marker tooltips will be shown when hovering over the marker’s triangle.
  • Added elapsed time, estimated total and remaining time to the video export dialog. These values are estimates only.
  • Added a Size Mode parameter to the Shape 3D node to allow mesh generation based on diameter or radius. Defaults to Diameter.
  • Added support for spline transformations to the Extruded Spline Geometry node.
  • Added curlErrorText and curlErrorCode to the Response object for use in NFetch and JavaScript.
  • Added a Triangle Count property to the Shape 3D node to indicate how many triangles the mesh generates based on the set parameters.
  • Added a Send to Render Queue for Transcoding context menu option for video resources in the Resource Browser.
  • Added snapping to range bar in the Timeline window.
  • Added a Bezier curve edit type to the Property window for editing particle life coefficients, for example.
  • Added Insert, Delete, Jump To Previous and Jump To Next options to the Timeline Markers toolbar menu button.

Changes

  • Removed 32-bit support of Notch Builder as well as block and standalone exports.
  • Updated the NDI Output node to always send RGBA8 streams and never try and send 16-bit streams, which NDI does not yet support.
  • Worked around an issue on the AMD WX9100 where shadows would not appear in some scenes.
  • Updated the width and height fields in the Video export dialog so that expressions can be entered and they are evaluated when you click off the text entry field.
  • Reduced Brightness of Sky Light node in Alembic Balls Sample to 8 from 16 to reduce overglow.
  • Updated all camera nodes to set the default near clip plane to 0.1 (instead of 0.01) to improve depth buffer precision, particularly in ray traced scenes.
  • Updated project saving to show a message box if the saved project file is less than 32 bytes on disk, which is indicative of a save problem.
  • Updated Notch License Check to show additional licensing information.
  • Before rendering a video, Notch Builder now does an auto save of your project.
  • Updated the Resource Browser to append to any Alembic files that do not load.
  • Updated the Timeline view to intelligently allocate the keyframe colours to avoid them clashing.
  • Updated the internal renderer to log more information when we lose the gfx device.
  • Updated the VideoProcessor application to not timeout when processing long render frames.
  • Updated the Keyboard Modifier node so that it doesn’t have a parent connection tab.
  • Updated the Property window to allow Ctrl+A to highlight the value or string.
  • Updated the node graphic for the Tilt Shift node so it matches other Post FX nodes.
  • Updated the Ruler so it draws all node time segments, not just the first.
  • Updated the scene accumulation buffer to use a 32-bit pixel format instead of 16-bit.
  • Updated the Property window so that entering a comma is now interpreted as a decimal point.
  • Updated the Render To Texture node to support Affecting Lights and Excluded Lights inputs for the Sky Light nodes.
  • The root node can no longer be deleted. Any imported bins containing a Root node are converted to Null nodes.
  • Updated to Cinema 4D SDK (melange) v20.004.
  • Updated from Spout SDK v2.004 to v2.006 (and additional fixes).
  • Updated to NDI SDK 3.8.
  • Updated to the latest version of the HAP SDK (April 5th 2019).
  • Updated the Area Lights From Polygons node to support the Affected Nodes input.
  • Updated the Point Lights From Vertices node to support the Affected Nodes input.
  • Updated the Render To Texture template project to make the timeline bars start at 0.
  • Updated the import video file filter to include *.mp4 files. These will be transcoded on import.
  • Renamed the Skybox Brightness parameter on the Skybox node to Brightness. This now matches the envelope name and added an alias for backwards compatibility.
  • Renamed the Colour 0 and Colour 1 parameters in the Composite Sources node to Input 0 Tint and Input 1 Tint respectively. Added aliases to maintain backwards compatibility.
  • Updated the FBX importer to fallback to the node name when the mesh name is not specified in the file.
  • Updated the Copy To Clipboard functionality to zero out node resources. Resource IDs between multiple instances of Notch will not match.
  • Dragging a .fx file from the Resource Browser window into the Nodegraph now creates a Custom Shader Post Effect node and assigns the shader to it.
  • Updated the Auto Key Mask Post FX node so that the Key Colour Source Image input can now be a generator node.
  • Updated the Resource Load Results dialog to add scroll bars so paths are no longer cropped.
  • Updated the Particle Root node to do more validation on what nodes can be connected to it as a child.
  • Updated the Video Loader node so that if Static Image is checked, but you try and animate or put modifiers on any of the properties in nodes attached to it, it warns you.
  • Updated the Timeline so segments are only split when the time is within the segment.
  • Updated the Downsample node so that if the Iterations parameter is set to 0, Post FX nodes still work.
  • Updated Notch Builder so that it will warn once about saving using a Learning license and that you will not be able to open the project in Base/Pro.
  • Updated the Star generator node by removing the 0-360 hard limit on the Orientation property. Shift+drag can now be used to extend in the in and out parameter values.
  • Updated the Bump Map Warp Post FX node so that it defaults to the frame buffer as the bump input image if nothing is connected to the Image Node input pin.
  • Removed the Curl Noise Amount Modulator input from Particle Curl Noise Fluid Affector node.
  • Updated Substance and CSV resources to report the time taken to load the file in the Resource Browser window.
  • Updated the Shape 3D node to disable the Axis parameter when using the Sphere shape type.
  • Updated the Geometry Line Renderer node so that when the Thick Lines parameter is disabled, parameters in the Smoke Attributes section are hidden as these will have no effect on the result.
  • Removed the duplicate Blend Amount parameters from Texture Shading nodes.
  • Updated particle rendering so the Particle Root Master Brightness Scale and Master Alpha Scale now have an effect on non-smoothing shading.
  • Updated the Geometry Line Renderer node to include support for a Colour node input.
  • Renamed the default parameters names in the Javascript node from “UnnamedParam” to “UnnamedInputParam” or “UnnamedOutputParam” to help the user distinguish if they are input or output parameters.
  • Updated the Glow Post FX node to ensure that the primary layer is used for masked glow sampling.
  • Updated the Voronoi 2D node so that it uses input colours from the Primitive Emitter particle node.
  • Updated the Material nodes so that the vertical order of shading nodes in the node graph is now taken into account.
  • Updated the Procedural Meshing node so that the material input can be controlled by the Input Selector Modifier node.
  • Updated the Procedurals Voronoi node so that only deformers that are enabled have an effect.
  • Updated the Ruler to highlight the timecode text when it matches the timeline marker timecode.
  • Updated the Random Cloner node so that it works with more than 16384 clones.
  • Deprecated the following nodes: IK Chain, Shatter Primitive 3D and Convert Geometry To Boxes.
  • Updated the Motion Datamosh node by changing the hold time targets to 32-bit, so they have a longer possible duration.
  • Updated the Timeline window to snap times to all individual segments and not just first segment.
  • Updated timeline segments in the Timeline window by drawing a thin line between segments when they are not selected.
  • Updated VR export to copy all the required DLLs and not just the OpenVR Dll.
  • Updated the Shape 3D node to not allow the Shape Type parameter to be exposable. Select Child Node and Shape 3D nodes should be used instead.
  • Updated the Timeline so that minimised nodes remain minimized when the project is loaded from disk.
  • Updated the video export dialog to report the time taken/remaining in HH:MM:SS rather than MM:SS:frames.
  • Updated the Combine Geometry node to work with clones and meshed/rendered into a procedural volume without the need for the overriding bounding box.
  • Updated the rendering of 3D lines so you are able to override the line colour on the node by attaching a colour node to the Lines Colour envelope.
  • Updated the Particle Image Affector node to hide unused parameters when the Mode is set to Displace.
  • Removed the Collision Mode parameter from the Particle Image Affector node as these had no effect.
  • Removed the Spread Angle and Image Search Mode parameters from the Particle Image Affector node as these had no effect.
  • Updated the Geometry Line Renderer node by adjusting the Gain parameter on the line smoke turbulence noise texture function to make the smokiness more apparent.
  • Renamed the Javascript node’s context menu item from Add Float Parameter to Add Global Input Parameter. Added an Add Global Output Parameter menu item too.
  • Updated the GBuffer To Image and Output GBuffer nodes to add support for Motion Vectors buffer output.
  • Reduced memory consumption when using the Mirror Deformer node.
  • Removed the Colour Ramp input from the Light Scattering Beam node as the primary use is for optimal non-sampling light beams for lighting previsualization.
  • Updated the Probe Lighting node so that the resulting buffers can now be ray traced and baked.
  • Updated Particle Event nodes so that they connect to the closest Particle Root when pressing the Ctrl+R shortcut.
  • Updated the Environment Map node so that the enabled/disabled state is taken into account.
  • Change the Multiplex Sources node shape so there is no left edge input which was not supported anyway.
  • Removed the Bevel Amount parameter from the Text node as it did not function.
  • Updated the Shape 3D node so that the Start Angle and End Angle parameters are no longer keyable. This is not supported.
  • Renamed the Quantise Deformer’s Amount parameter to Displacement Amount so it can be hooked up by dragging a connection from the Nodegraph to the Property window.
  • Updated the Particle Geometry Connection Renderer so that it works in conjunction with deformer nodes.
  • Updated property sliders so that pressing Alt+R to reset the value now also resets the slider ranges. When resetting slider ranges using Alt+R, user-defined min and max values are removed.
  • Renamed the Scratch Region Properties dialog title to Playback Range Properties.
  • Updated the JavaScript GetNodes() and GetNodeCount() API to also include nodes within Groups.
  • Updated the Transform Array node so that it now works with respects the enabled or disabled state of a node as well as time bars.
  • Updated the Extruded Spline Geometry node so that it works with time bars.
  • Updated nodes that have IP address parameters to only update once Enter is pressed or the parameter is deselected. For example, NDI Output, XSens Mocap Skeleton, etc.
  • Updated the tooltip for an Imported 3D Scene node to include the filename of the scene file.
  • Renamed the Shadow Volume node’s Strength parameter to Brightness.
  • Updated the Field Primitive Affector node so that it now works in 3D.
  • Removed Focal Plane Distance, Focal Range and Focal Bluriness parameters from the Cylindrical Camera node as these are not supported.
  • Increased the size of the Min and Max framerate text in the Ruler so it is more visible.
  • Updated the Material node to expose an Ambient Occlusion Map texture slot.
  • Improved the projection mapping for the Cylindrical Camera node.
  • Updated the video export dialog so some fields now only accept numbers and validation/expression parsing is performed.

Bug fixes

  • Fixed geometry corruption bug when using the Cull Deformer or Mirror Deformer node.
  • Fixed a bug in the Region node so that it now correctly clips text.
  • Fixed a crash when clicking on the Remove button in the Feed Configuration dialog.
  • Fixed a crash when using the Render To Surfaces node.
  • Fixed a crash when deleting timeline markers.
  • Fixed a bug which meant you could not type [ or ] into the node search box.
  • Fixed a bug in the WebGUI interface that meant exposed resources, such as Video, would become deselected when refreshing the webpage.
  • Fixed a licensing issue in Notch.exe, which meant that expired subscriptions would not fall back to the Learning license if available.
  • Fixed a bug where dragging and dropping multiple 3D scenes directly into the Nodegraph would show an import dialog per file rather than 1 for all files.
  • Fixed a bug when undoing deleted nodes that were located in a Group.
  • Fixed a bug where area lights did not work correctly when their scale was set to zero.
  • Fixed a bug where property values for nodes retrieved from bins would not be present in the Copy To Clipboard plain text data string.
  • Fixed a bug which meant that jumping to the next or previous timeline marker did not actually select it.
  • Fixed a bug when saving .avi video files as an image strip.
  • Fixed the Shift+End shortcut when a Timeline Range is active to move the playhead to the end of the Range, not the end of the layer.
  • Fixed a bug in the Particle Point Renderer node which would cause animated sprites to jitter.
  • Fixed a bug in the Procedural Reaction-Diffusion node which was causing the last input envelope to not appear when expanded in the Nodegraph.
  • Fixed a bug when rendering the splash screen project thumbnails which could cause rendering artifacts to appear.
  • Fixed a bug in the Shape 3D node where the normal would be incorrect if Flip Direction was selected for a Plane shape type.
  • Fixed the orthographic camera zoom functionality to work with Alt like in perspective views.
  • Fixed the Extruded Spline Geometry node so that it handles multiple splines correctly.
  • Fixed a bug in the Extruded Spline node, which means the bounding box is now more accurate and fixes some ray tracing artifacts.
  • Fixed a bug in the shadowmap rendering which did not include material mapping when applying a displacement map.
  • Fixed a bug in the Tone Map node when using Reinhard or Filmic modes, which could have caused some rendering artifacts.
  • Fixed a bug in the Spline node, which was ignoring the enabled/disabled state of Spline node inputs.
  • Fixed a bug which was causing an incorrect bounding box to be calculated when using procedurals with deformers.
  • Fixed a bug in the Distortion and Turbulence Deformer nodes which meant the Max Displacement parameter was not exposed in the UI.
  • Fixed a bug where the output texture from video nodes was not being set properly on materials used on 3D Object nodes and therefore mipmaps were not being generated.
  • Fixed a number of bugs in the Gradient Patch node.
  • Fixed a bug with FBX per-poly UVs on animated topology files not animating properly.
  • Fixed a number of undo issues throughout.
  • Fixed a bug in the Environment Map node which meant the background colour fallback was not always being taken into account during lighting calculations.
  • Fixed a bug in the material property group where the emissive texture was being used as ambient occlusion texture when set via the node input connection.
  • Fixed a crash when applying the Generate Fertilizer Times Deformer node to a Procedural Meshing node.
  • Fixed a bug in node targeting by avoiding invalid transforms when the parent scale is set to zero.
  • Fixed cropped text in a number of dialogs.
  • Fixed a number of bugs in the Field Cache node when compressing the field data into the cache.
  • Fixed a bug copying DLL dependencies when exporting standalone applications.
  • Fixed a bug which stopped the Colour Ramp input on the Polygon Generator node from working correctly.
  • Fixed a bug when flipping the image used by the Particle Image Affector node.
  • Fixed a bug which stopped the Colour Ramp input on the Star Generator node from working correctly.
  • Fixed a bug in the Voxel Cone Lighting node which could cause geometry to be missing from the render.
  • Fixed the various Preview In Viewport options in the Video NDI Source node so that they are mutually exclusive.
  • Fixed a bug when clicking the Refresh Sources button in the VideoIn/Camera/Kinect Settings dialog. It was not reliably picking up new and existing sources.
  • Fixed a Null transform inheritance bug when the parent null has a zero scale on one of its axes, resulting in an inverse of zero scaled matrix.
  • Fixed a bug in the Combine Geometry node which meant the bounding box for the geometry would not always be accurate.
  • Fixed a bug in the Javascript node which meant the Input Parameters and Output Parameters groups in the Property window would change order when adding new parameters.
  • Fixed a bug in the Clone To Mesh node, which meant the area calculation for surface spread mode was not normalised, causing the cloner to fail on some meshes.
  • Fixed the rendering of Procedurals when using the Particles As Primitives node.
  • Fixed numerous bugs in the Particle Image Affector node.
  • Fixed a bug when merging projects which could cause node links to be removed.
  • Fixed a bug in the Timeline view when using the Add Time Marker context menu option.
  • Fixed a number of bugs in the Combine Geometry node to make it work better with deformers.
  • Fixed a bug when using Area Light nodes, which would cause Z-fighting when forward rendered.
  • Fixed a crash bug when loading curves with less than four points from FBX files.
  • Fixed a bug which could cause Notch to crash when loading project thumbnails.
  • Fixed a bug where VR applications would always choose to use the Oculus headset.
  • Fixed a bug in the Voxel Cone Tracing node where gridspace / worldspace transformations for non-uniformly-scaled bounding boxes were not being performed correctly.
  • Fixed a bug when rotating camera nodes with an orthographic projection.
  • Fixed a bug when transcoding videos which could cause the resulting video to be skewed.
  • Fixed a bug where properties exposed to groups were not being exposed correctly in exported projects.
  • Fixed a number of transform bugs in the Field Level Set Root node, so it now behaves like the regular Field node.
  • Fixed a bug when validating paths which ended up removing the last character. This fixes path issues when editing the bin/cache/screenshot paths in the File->Preferences dialog.
  • Fixed a bug relating to aspect ratio in the Gradient generator node.
  • Fixed a number of bugs when transcoding video files which could cause Builder to crash.
  • Fixed a bug when lassoing time segments in the Timeline window.
  • Fixed a Timeline bug when dragging multiple node bars selected with Shift. Previously it was not keeping the selection.
  • Fixed a bug when dragging and dropping a video resource into the Nodegraph which incorrectly set the framerate of the video.
  • Fixed a bug when undoing a shift and drag selection of nodes in the Nodegraph.
  • Fixed a bug where extra black frames were being added at the end (for no motion blur) or the start (for motion blur) to an exported video.
  • Fixed a polygon winding order bug in the Alembic file loader.
  • Fixed a bug in the Alembic object deformer bounds generation for animating topologies.
  • Fixed a bug in the Procedural Meshing node where multiple connected material nodes were not being handled correctly.
  • Fixed a bug when time segment splitting layers so it does not insert a gap in between the segments.
  • Fixed a bug with orthographic cameras which produced incorrect reflection ray directions when used with the Voxel Cone Tracing node.
  • Fixed a bug when using deformer nodes which meant motion vectors were set incorrectly.
  • Fixed the alignment of the Ctrl-F key text for button properties in the Property window.
  • Fixed undo support when editing keyframes in the Timeline view via Shift+Up/Down, Alt+Left/Right shortcuts.
  • Fixed a bug in the Sky Light node which meant the environment map image would not be visible on the first frame.
  • Fixed the UVs for the Rounded Cube shape type in the Shape 3D node.
  • Fixed a number of bugs relating to time segments, including copying and pasting and segment names.
  • Fixed the fact you could not enter capital R in Text nodes for strings.
  • Fixed a bug where clicking View->Load Layout did not take you to the default “Documents\Notch\Notch Layouts” folder.
  • Fixed a bug where we were not correctly setting the initial directory for the File Open dialogs.
  • Fixed a bug in the FBX file loader relating to skinning. Notch supports only 4 bone weights but we were not using the top 4.
  • Fixed zooming to selection in the Curve Editor so it actually fits the selection.
  • Fixed a bug editing Bezier 2D tangents when keys are created in Property editor.
  • Fixed a bug when using Material nodes with Video Loaders as they would still be used as colour texture inputs even when they were disabled.
  • Fixed a bug in the Curve Editor where selecting all the keys now jumps to the correct time.
  • Fixed a bug in the Timeline window when dragging the start of a layer bar with Shift pressed.
  • Fixed up the various key interpolation type menus so that they all display the same interpolation options. Previously there was a mismatch throughout.
  • Fixed a number of UV issues when using the Combine Geometry node.
  • Fixed a WebGUI bug which meant the user-defined min and max properties were not being respected.
  • Fixed a bug when calculating the bounding box of some objects with deformers.
  • Fixed the GBuffer To Image and Output GBuffer nodes to work correctly with 360 Camera nodes.
  • Fixed a number of bugs relating to baked lighting including specular highlights erroneously appearing in the baked result.

Known Issues

  • VR GUI is not showing correctly on all VR headsets. Fix expected in next maintenance release.