0.9.22.059 (2nd patch release, 29th July 2019):

Bug fixes

  • Fixed a licensing issue in Notch.exe which meant that expired subscriptions would not fall back to the Learning license if available.
  • Fixed a bug in the Particle Point Renderer node which would cause animated sprites to jitter.
  • Fixed a crash when using the Render To Surfaces node.
  • Fixed a crash when clicking on the Remove button in the Feed Configuration dialog.

0.9.22.053 (1st patch release, 26th June 2019):

Added Nodes

  • None.

Added Shortcuts

  • Added Ctrl+Shift+M shortcut for opening the video export dialog.
  • Added Shift+R shortcut for toggling Refine Render.
  • Added Ctrl+U shortcut for Copy To Clipboard.
  • Added Ctrl+I shortcut for Paste From Clipboard.
  • Added Ctrl+Shift+N shortcut for New Layer.

Added Features

  • Added an option to change the Depth Range in the Luminance From Depth node. Options include Kinect v1, Kinect v2 and Raw Depth.
  • Added unicode string support to enable updating exposed text strings via WebGUI.
  • Added a Refine steps count to the Status Bar.
  • Added a Radial Rotation Offset parameter to the Extruded Spline node.
  • Added a UV Mode parameter to the Extruded Spline node. Added a Spline Time mode that locks the UV to the spline point time.
  • Added node presets for the RT Denoiser node.
  • Added a Calculate Distance bin, which calculates the distance between two nodes and outputs the value.
  • Added a Calculate Midpoint bin, which calculates the midpoint between two nodes and outputs a position you can child other nodes to so they follow that midpoint.
  • Added the ShadowCatcher.dfx project that was previously in the additional Samples pack into the Notch installer.
  • Added support for sending a layer bin to a specific folder in the Bins Window.
  • Added a texture input pin to the Halftone Post FX node.

Changes

  • Deprecated the Bake Lighting node. Please see the Bake Lighting To Object node for baking lighting in your scenes.
  • Updated the Region node so that Shift+Drag only moves child nodes that are fully within the region.
  • Updated the Fractal Noise Shading Node to disable the Offset Amount parameter when using the FBM or Turbulence Noise Type.
  • Updated the Downsample Iterations parameter on the FFT Blur / Glow node to set the min and max slider range to 2 to 16.
  • Updated standalone applications to generate mipmaps for image resources. This now matches the behaviour in Notch Builder.
  • Render refinement is now only enabled if ray tracing is turned on for an active layer in the current time scope.
  • Removed the ability to disable Region and Comment nodes. You couldn’t disable them anyway and attempting to do so was confusing the GUI.
  • Updated the Procedural Shading Node so that it connects to the closest Procedural Root node when the pressing Ctrl+R shortcut.
  • Removed unused Shift+F11 shortcut.
  • Updated the Tweening Null node so that it now works with Cloner nodes.
  • Updated the export video progress dialog window so that it is now moveable.
  • Updated the image file loader to correctly classify image formats in the Resource Browser window.
  • Updated the Paste From Clipboard functionality to paste the nodes to the position of the mouse cursor if in the nodegraph, otherwise to the centre of the nodegraph.
  • Disabled the ability to copy the Root node when using the Copy To Clipboard feature.
  • Updated the DFX project loader to ensure that node GUIDs are unique across all layers. Duplicate GUIDs can cause issues with the undo stack.
  • Removed the RT AO bin. This will be resurrected for the Notch 0.9.23 release.
  • Updated the Skylight node so the Raytraced Samples parameter is set to 1 by default.
  • Updated Material bins to ensure that the 3D Objects are positioned at the origin.
  • Deprecated the Clip Box node. This has been replaced by the Cull Deformer node.
  • Updated the Skylight node so the Lock To Camera parameter is enabled by default.
  • Updated the Expression node to support calculating floating point remainders. Previously, value0%value1 would round down the resulting value.

Bug fixes

  • Fixed a crash when instantiating bins containing textures, then closing Notch Builder or opening/creating a new project.
  • Fixed a bug in the Region node, which meant the outline of the region in the Nodegraph would be rendered using the wrong colour.
  • Fixed a bug in NFetch that meant the saveToPath request would not create the destination directory if it did not exist.
  • Fixed the formatting of some error messages written to the log file.
  • Fixed a bug when loading and importing files from unicode paths.
  • Fixed a bug in the Water Ripples Post-FX node which caused rendering artifacts when the Length parameter was very close to zero.
  • Fixed a bug in the Luminance From Depth node’s texture preview scaling.
  • Fixed a bug in the Skylight node, which was incorrectly applying a ray bias in the reflection pass.
  • Fixed a bug in the Timeline window when rendering curves for nodes inside layers with multiple time segments. Sections of the curve were displayed multiple times.
  • Fixed a bug in the Curve Editor window when rendering curves for nodes inside layers with multiple time segments. Sections of the curve were displayed multiple times.
  • Fixed some menu item typos relating to shortcut key commands.
  • Fixed the Frame Feedback node so that Ghost Offset X and Y parameter can now be set by dragging a connection to the Property window.
  • Fixed a camera movement bug, which meant that pressing and scrolling the mouse wheel at the same time would cause objects to move position arbitrarily.
  • Fixed a bug relating to 3D Objects, which would cause line rendering to flicker when the Subdivision Levels parameter was changed.
  • Fixed a bug in the Colour Ramp node, which meant that the preview in viewport checkbox would not be disabled if you previewed a different node, such as Video Loader.
  • Fixed a bug where resource load times were not being calculated when reloading or importing a resource (only when loading a DFX from scratch).
  • Fixed issues with node links when copying and pasting via the clipboard feature.
  • Fixed a bug in the Merge Resources By Filename option in the Resource Browser. It was incorrectly deleting unused resources even if they had a unique name.
  • Fixed a bug which meant the viewport was not updating after deleting a resource.
  • Fixed a bug in Spout output, which could cause the spout receiver to receive black frames until the viewport is resized.
  • Fixed a crash when switching projects when the Refine Render option is enabled.
  • Fixed a bug when using non-ascii characters in the folder paths specified in File->Preferences.
  • Fixed a bug where the nodegraph button tooltips would appear when hovering over nodes and connections, which was very annoying.
  • Fixed a bug in the Skybox node, which meant the Blur Amount parameter did not behave as expected.
  • Fixed a bug in the Skybox node, which meant that it did not show on the first frame of a render when the image was supplied from the Environment Map node.
  • Fixed a bug in the Quicktime GPU compressor, which was causing some rendering artifacts and reduced quality compared to Quicktime for Windows exports.
  • Fixed a bug in the Expression node when using the % operator which would result in a crash.

0.9.22.043 (official release, 6th June 2019):

Added Nodes

  • Cloning
    • Clone Cache | Allows baking of cloner animations to disk, and playback of baked cloner animations.
  • Deformers
    • Cull Deformer | Cuts away the polygons of the affected object using a plane, box or sphere.
    • Generate UVs | Allows you to generate UV coordinates for the deformed object using a mapping.
    • Mirror Deformer | This can be used to mirror geometry from one side to another and combine the output into a single mesh.
  • Fields
    • Deformers->Fbm Deformer | Deforms a field based on the Fractional Brownian Motion algorithm.
    • Field Cache | Allows you to store the animation of a field to disk for scrubbale, deterministic playback.
  • Generators
    • Truchet | Generates a texture of a Truchet pattern.
    • Voronoi | Generates a texture of a Voronoi pattern.
  • Geometry
    • Decal | Use this node to project a texture onto a surface.
    • Optitrack Mocap Skeleton | This node reads bone data from a Optitrack motion capture suit and applies it to Bone nodes.
    • Transform Array Extractor | Extracts data from CSV/Table transform array node.
    • Tweening Null | Allows for a smooth transition between a number of transformation values.
  • Interactive
    • Blacktrax Tracked Body | Takes a single Blacktrax Trackable and provides it as a tracked point (a bit like Null).
    • Blacktrax Transform Array | Takes multiple Blacktrax Trackables and instantiates the child nodes at the tracked points.
    • TUIO Transform Array: Generates a transform array from TUIO data sent from an external app supporting the TUIO protocol.
  • Lighting
    • Bake Lighting To Object | This node bakes static lighting information for objects into lightmap textures.
  • Materials
    • Alpha Blend (Transparent) Material | This is a basic transparent material using an alpha blend.
    • Diffuse Material | A basic diffuse material, similar to the default material node but without any specular settings.
    • Emissive Material | A basic emissive material, similar to the default material node but without any specular settings.
    • Metallic Material | A basic metallic material, similar to the default material node but default metallic settings.
    • Shadow Catcher Material | Captures shadow information from lights cast onto surfaces that apply a shadow catcher material.
    • Substance Material | Supports applying Substance materials to meshes and real-time texture updates.
  • Nodes
    • Image 2D Equirectangular | Warps a cube map into an equirectangular image in 2D space.
    • Region | Allows you to create a coloured region directly on the Nodegraph.
  • Particles
    • Affectors->Depth Image Collision Affector | Simulates collisions between particles and a Kinect depth image.
    • Affectors->Rigid Body Collision Affector | Simulates collisions between particles and a rigid body system.
    • Particle Cache | Allows you to store the animation of particles to disk for scrubbale deterministic playback.
  • Physics
    • Phsics->Rigid Body Depth Image | This node is used to allow Kinect depth to collide with mesh in the rigid body simulation.
  • Post-FX
    • Colour Processing->Colour Channel Mixer | Use the colour values from the different colour channels and blend them together.
    • Image Processing->NDI Output | Sends the video or scene render it is attached to out via NDI.
    • Image Processing->Output GBuffer | Outputs various GBuffers to the screen. GBuffers are geometry buffers.
    • Warping->Barrel Distortion | Used to simulate or correct distortions in real-world camera lenses.
    • Warping->Droste Warp | Applies a Droste function to the image, creating an infinite warp.
    • Warping->Moebius Warp | Applies a Moebius function to the image, creating an infinite warp.
  • Ray Tracing
    • RT Denoiser | This node is used to control denoising parameters for the scene.
    • RT Mirror Reflection | This node is used to simulate mirrors, reflections and specular on any raytraced material or surface.
  • Video Processing
    • Input Output->GBuffer To Image | Allows GBuffer channels from a rendered scene to be used as video nodes.

Added Shortcuts

  • Added Ctrl+R so that a range of nodes, now connect to their closest suitable parent root.
  • Added F11 and ~ key to display the Nodegraph window as fullscreen.
  • Added Ctrl+1 in the Timeline window to toggle layer enable/disable.
  • Added [] to trim time bars.

Added Features

  • Added Unicode support.
  • Added Substance support. See the Materials->Substance Material node.
  • Added support for raytracing to Sky Light, Area Light, Light (omni/spot) and Directional Light nodes.
  • Added new viewport navigation controls (Alt + LMB / MMB / RMB)
  • Added much wider video codec import support, through a new automatic transcoder to NotchLC.
  • Added support for baking lighting to textures on correctly UVed meshes with Lighting->Bake Lighting to Object node
  • Add support for baking clones, fields and particles. See relevant ‘Cache’ nodes.
  • Added GBuffer export (see GBuffer To Image and Output GBuffer nodes)
  • Added Timeline Markers, use Ctrl+M to add new markers and Ctrl+Alt+Arrow to jump between prev and next markers.
  • Resource load times are shown in Resource panel (for most filetypes). Helps long loading resources.
  • When live editing, exposed parameters may be sent back from host app/media server into Builder – controlled via the Connection Monitor.
  • Added 2D bezier interpolation of keyframes
  • Added Shadow Catching (see Materials->Shadow Catcher Node and Material->Shadow Catcher Colour)
  • Curve Mask overhaul to more easily used to mask video/images directly. Control points can now be keyframed. The contour must be closed manually to be filled. Improved visualisation.
  • Added TUIO multi-touch surface support. See the Interactive->TUIO Transform Array node.
  • Added Xsens motion tracking support.
  • Text node now supports 2D bitmap rendering
  • Added support for exporting 16-bit channel .exr image sequences.
  • Added 16-bit RGBA floating point support to video export and rendering / compositing path throughout.
  • Added the ability to select the camera to render the scene from in the export video dialog.
  • Added a “Check for Updates..” option to the Help menu.
  • Added additional toolbar buttons including, “Refine Render” and “Prioritise UI Updates”.
  • Added beta support for exporting Proxy blocks.
  • Added Blacktrax support [Beta].
  • Added a “Video->Image Sequence” option to the import resource menu item.
  • Added a “Smoothing Angle” parameter to materials, to control the normal smoothing angle per surface for deformed objects.
  • Added feathering support to the Freehand Mask and Curve Mask nodes.
  • Added support for importing points from Alembic files, to be used as particle caches.
  • Added Notch Product Specialist created Lighting and Material bins.
  • Added Notch Product Specialist created Node presets.
  • Added NFetch support to the Javascript API. This allows users to make asynchronous HTTP requests and then invoke a callback function with the result.
  • Added Layer.GetNodes() and Node.GetNodeGraphPosition() to the Javascript API.
  • Improved the performance of saving and loading large project files by making compression of project files optional. Added “Project Compression” tick box to Project->Settings dialog. For quicker saves, but larger files, untick this option.
  • Added support to the Custom Shader Post Effect node to allow for texture inputs.
  • Added “Colour”, “Blend Mode” and “Blend Amount” parameters to the Particles: Shading: Density Shading node.
  • Added “Preview In Viewport”, “Preview RGB In Viewport” and “Preview Alpha In Viewport” options to a number of nodes, including Video nodes, Generators and Colour Ramps. Checkerboard mode added for visualising RGB+Alpha together.
  • Added native Animation codec playback support so it works in both 32-bit and 64-bit Notch versions.
  • Added “Num Blocks X” and “Num Blocks Y” parameters to the Digital Block Glitch node to ensure the effect looks the same when the output resolution changes.
  • Added “Num Blocks X” and “Num Blocks Y” parameters to the Digital Chroma Glitch node to ensure the effect looks the same when the output resolution changes.
  • Added a new “Duration” group to the export video dialog:
  • Added a “Use Range Duration” button to set the start and end time of the export to match the specified range set in the project.
  • Added Stype support to the “Connection Monitor” dialog.
  • Added support for dragging multiple nodes from the node tree into the node graph.
  • Added Y axis subdivision support to the Shape 3D node for the Curved Plane shape type.
  • Added an “Invert Order” checkbox to the Colour Ramp node to add support for reversing the order of the colours.
  • Added Notch license information to the Help->About dialog.
  • Added “Blend Amount” and “Blend Modes” to the Crop node.
  • Added a “Use Project Resolution” button to the export video dialog.
  • Added a button to clear the recent file list in File->Preferences.
  • Added support for duplicating entries in the render queue via right click->Duplicate.
  • Added support for multiple input images to be provided to the Skybox node.
  • Added missing tooltips throughout Builder.
  • Added support for importing more than 1 bin at once via the “File->Import Bin..” menu option.
  • Added a “Set As Background” parameter to the Image 2D node.
  • Added a tick box in File->Preferences for disabling the loading of thumbnails from dfx project files.
  • Added colour-depth alignment support to our RealSense2 integration.
  • Added support to the property editor to allow for inline editing of strings.
  • Added support for entering expressions, such as 1920*3, to the rendering output resolution width and height boxes in Project Settings.
  • Reduced NotchLC’s CPU overhead even more, by switching LZH to LZ4 CPU-side compression.
  • Added support for double-clicking in the Resource Browser window to open a file import dialog to select any Notch supported file type.
  • Added checks for available free disk space prior to saving files in Builder. If there is not enough free space to save the file then error accordingly.
  • Added support for double-clicking on a key in the Timeline window to edit its value in place.
  • Added a new checkbox called “Lock To Camera” to the Geometry: Skybox node for locking the skybox to the camera’s position.
  • Added colouration support and standard blending properties to the Mirror node.
  • Added colouration support and standard blending properties to the Clone node.
  • Added support for getting the graphics card driver version, which is now written to the log file to help diagnose issues.
  • Added a “Vertices – Follow Edges” spawn mode to the Particle Mesh Emitter node.
  • Added mesh reveal controls to the Particle Mesh Emitter node so Fertilizer can be used to control the emission area.
  • Added a limiter parameter to the Particle Mesh Emitter node for the number of emissions per vertex, in vertex mode.
  • Added the Notch Builder version number string to the Samples splash screen.
  • Added more keyboard controls to Standalone executables. Use Space to toggle playback and Home to restart the selected layer.
  • Node search box improvements: Added Home and End support. Added Ctrl+left or right to move caret along a word/separator. Added Ctrl+shift+arrow to move caret and highlight word.
  • Added a mirror wrap mode option to a number of nodes throughout. For example, Transform Image, Material, Image Plane and Image 2D nodes.
  • Added Face Heading, Pitch Estimation and Face Size parameters to the Face Tracking node.
  • Added an “Offset” parameter to the Procedural Onion node for adjusting the thickness of the generated layers.
  • Added support for rendering fullscreen on a third monitor via the Shift+F9 shortcut.
  • Added a new “Follow Surface” mode to the Object Distance Field Affector node.
  • Added “Streak Difference As Alpha” option to Streaks and Glow Post FX nodes.
  • Added “Nodes”, “Disabled”, “Hidden” and “Unconnected” counts to the top left of the Nodegraph window.
  • Added a “Trim Time Bar to Clip Length” context menu option to the Video Loader node.
  • Added support for Radial Square and Rounded Square modes to Gradient generator node.
  • Added an “Effect Amount Image” input to a number of Post-FX nodes, such as Streaks and warp nodes.
  • Added update time mode support to the Curl Noise Warp Post FX node so that it can repeat seamlessly.
  • Added a “Hard Change Threshold” parameter to the Smooth Envelope Modifier node so if value difference goes beyond this perform a hard jump.
  • Added an “Outer Only” mode to the Procedural Onion node to complement the existing “Inner Only” mode.
  • Added a new mode for creating radial symmetry with any number of rotations to the Procedural Mirror node.
  • Added a Mapping input to the Generate Fertilizer Times Deformer node.
  • Added modes for simple left/right and up/down linear gradients to the Gradient generator node.
  • Added an “Active” parameter to the 3D Object Outline node.
  • Added an input node to allow an image node to be connected to the Colour Image Ramp node.
  • Added a depth bias adjustment property to the Screen Space Reflections node.
  • Added “Colour R”, G, B and A extractor envelopes to the Video Sampler Modifier node for getting individual colour values.
  • Added an “Optimise Memory Usage On Idle” parameter to the Layer Precomp node.
  • Added “idle” mode to rigid body nodes. Bodies go idle when they have not moved in a while and stop simulating, until affected/moved again by another body/force etc.
  • Added the ability for multiple nodes to be hooked into alpha mask input on video nodes so they can all be blended.
  • Added bar minimisation to the Timeline window.
  • Added support for a texture input option on the Cross Hatch Post-FX node.
  • Added, “Fbm”, “Turbulence”, “Ridged Multifractal” and “Marble” noise types to the Fractal Noise generator node.
  • Added a “Uniform Scale” parameter to the Ripple Effector node.
  • Added presets dropdown to the “Project->Settings->Rendering” dialog for choosing typical output resolutions for social media, 360 video etc.
  • Added the ability to set separate sender and receiver ports for OSC.
  • Added the ability to sample the average colour from a rectangular area in the Video Sampler Modifier node.
  • Added a “Normalise Spline Time” option to the Spline node.
  • Added support for various missing Geometry Node types to the Affecting Objects input of the Voxel Cone Lighting node.
  • Added WIP->Geometry Network Sender and WIP->Geometry Network Receiver nodes, to allow geometry to be sent in and out of Notch via network streams. If you plan on using these then please get in touch via support.
  • Added additional logging for detecting NDI failures.
  • Added thumbnails to the Timeline window to enable users to see frames of video.
  • Added support for 360 camera and multi cameras to the Procedural Volume Generator node.
  • Added the current Pixel Scaling setting value to the status bar in Builder.
  • Added “Delete All Keyframes For Selected Nodes” to the Edit menu.
  • Added a checkerboard preview in viewport mode to the Video nodes.
  • Added a “Gravity” parameter to the Field Level Set Root node.
  • Added the option to use unmodified colour channel UVs for output in the UV camera node.
  • Added the ability to use a Transform Array node as the points for a Spline node.
  • Added support for child nodes to a lot of procedural types, and added child node dirtiness checks.
  • Added colour generation to the Procedural Volume Generator node.
  • Added support for particle colours to the Procedural Particles As Primitives node.
  • Added a node input for the texture map image to the Procedural Meshing Texture Map node.
  • Added a new mode for the cylinder and torus shape type, which gives it flattened sides to the Procedural Primitive node.
  • Added a “Blend Mode” parameter to the Particle Life Colour Shading node.
  • Added an environment map input, separate diffuse and specular brightness parameters to the Probe Lighting node.
  • Added a “Smoothing Angle” parameter to the Extruded Spline node.
  • Added a “Add to Alpha” blend mode parameter to the Particle Attribute Shading node.
  • Added a “Num Octaves” parameter to the Displacement Deformer node.
  • Added “Time to Idle” and “Idle Distance Threshold” parameters to Rigid Body nodes.
  • Added support for forward advection to the Fluid Solver to b used with level sets.
  • Added undo support to colour dropper control.

Changes

  • Updated to use FBX SDK 2019.2.
  • Upgraded Builder to support NDI SDK v3.5.
  • Improved the Video Export pipeline to allow even bigger resolutions and bit depths.
  • Improved network editing stability
  • Much-improved PNG loader performance
  • Updated the Nodegraph to allow selected nodes to be deselected by clicking on them whilst holding Ctrl.
  • Updated a number of nodes in the Nodegraph to be hatched out if their inputs are not valid or set correctly.
  • Updated the Combine Geometry node so that it accepts all kinds of cloner input nodes.
  • Changed the watermark to use a checkerboard pattern.
  • Changed String Edit fields so Shift+Enter now creates a new line and Enter on its own simulates pressing the OK button. Works great for comment nodes etc.
  • The export of standalone applications and media server blocks now defaults to 64-bit. Untick “Create 64 Bit Target” to export to 32-bit targets.
  • Updated Deformer nodes to that when Falloff is disabled, so are the associated parameters.
  • To help reduce memory usage, resizing the render window does not resize while dragging.
  • Updated Procedural Primitive nodes so they can now have child-parent transformation connections and both be rendered properly.
  • Updated the Volumetric Tracer node so that it correctly outputs alpha.
  • Disabled the grid rendering when exporting a video.
  • Updated the Digital Chroma Glitch node to reset timers accordingly when layer time is reset.
  • Updated Standalone applications using the “locked to timecode / reset on loop” mode to actually loop (and reset).
  • Updated the Ruler to render line markers on timeline frames when zoomed in.
  • Disabled the “Sample Location U1” and “V1” property when not sampling a rectangle in the Video Sampler Modifier node.
  • Updated the Nodegraph so that link output lines are ordered by the vertical position of the destination nodes in the graph.
  • Enabled the saving of project thumbnails to be on by default. These thumbnails will appear in the Recent Files tab from the Samples splash screen.
  • Updated the screenshot functionality to disable the orbit camera pivot handle prior to saving.
  • Updated the Area Light node to be single-sided and default to rendering the “Visible Surface”.
  • Updated Procedural Renderer nodes so they check for whether the Procedural Root is enabled or not before rendering.
  • Updated the Film Grading node to support the blurring of the alpha channel.
  • Removed newlines from the “OSC Address” parameter and Javascript input/output parameter names.
  • Updated the property control window to not show decimal places for integer properties.
  • Updated Mapping nodes so they now apply vertex displacement too.
  • Updated Procedural nodes to that when colours are used (and e.g. “Affect Colours” is enabled), then they now respect the geometric blending in their own blending.
  • Updated the Multiplex Sources node so that it now works with DXT image inputs.
  • Updated the Performance window to keep polling our website for comparison data if it fails on the first attempt.
  • Updated the Voxel Cone Lighting node to support a number of object input types.
  • Changed the Material node’s “Smoothing Angle” parameter to default to 45.0 instead of 89.0.
  • Renamed the “Displacement Direction” parameter to “Displacement Direction” throughout all nodes.
  • Renamed the Spline Affector node’s “Velocity Scale” parameter to “Velocity Amount”.
  • Removed sound markers as they have been replaced by real timeline markers.
  • Pressing F5 when a Comment node is selected now automatically opens the Edit String dialog to update the comment description.
  • Updated drag and drop support in Resource Browser window to accept .tif and .gif files.
  • Renamed the “Show Bounding Boxes While Playing” menu item to “Show Bounding Boxes And Range Indicators While Playing” to be representative of what it actually does.
  • Moved the “Delete Resource” context menu item in the Resource Browser closer to the top.
  • Combined the “Submit Result” and “Compare Results” button on benchmarking dialog into one button called “Submit And Compare Results”.
  • Changed the styling of Notch’s tooltips.
  • Updated the Auto Key Colour Mask node so that it now has Alpha enabled by default for the affected channels.
  • Updated the Stretch node so that the “Rotation” parameter is now in degrees not radians.
  • Updated the “Removed Unused Resources” context menu in the Resource Browser to also remove empty folders.
  • Updated the property control so that you can no longer set min and max values for drop-down menu parameters.
  • Replaced references to “PLE” with “Learning” throughout Builder.
  • Removed “Save Optimised..” from File menu as it is no longer supported.
  • Updated the property window so that you can now use Alt+mouse wheel to traverse through drop-down parameter options, such as blend modes and resources.
  • Disabled the “Subdivisions Y” parameter for a Shape3D’s Circle shape type.
  • Disabled the “Subdivisions Y” parameter for a Shape3D’s Ring shape type.
  • Updated ? colouring for exposed parameters and set min max properties. White if min/max and exposed, light baby blue for exposed only, and darker basic blue for set min max only.
  • Updated the AVI2 video export to now include audio support.
  • Updated the Ctrl+E shortcut to now highlight the text by default.
  • Disabled the ability to cut and then paste more than 1 root node into a layer.
  • Renamed the Render Layer node’s “Layer Alpha” parameter to “Alpha” to match envelope name.
  • Updated the C4D importer to retrieve the framerate from the file so the “Locked Frame Rate” parameter value is correct during import.
  • Change Nodegraph spline connections to straight lines.
  • Removed in-built Screen Capture support from Builder as 3rd party solutions fill this gap well.
  • Updated the Curve Mask node so that masks now have to be closed by clicking on the first point.
  • Updated the FBX importer to load tangent data if it exists.
  • Updated the Render Window so that resizing causes a VRAM purge.
  • Changed the render window composite buffer format in Builder from 8-bit to 16-bit.
  • Considerably improved the stability of rendering to video from within Builder.
  • Removed the “Sampler” mode from the video export dialog.
  • Increased the Render To Texture node’s maximum resolution of from 8k (8192) to 16k (16384).
  • When saving a bin, no longer include resources that have been marked as offline in the Resource Browser.
  • Increased the hit radius of the points in the Curve Mask node.
  • Improved the Face Tracker node to detect open mouths better.
  • Moved the number of entries a CSV file has into the extended description box in the Resource Browser. Adding it to the name broke Javascript resource reloading.
  • Disabled mouse wheel support for changing manipulator type in the render window.
  • Made sure that the PresetsDirectory path is written to the registry on startup and not just when creating a preset. Previously this caused issues moving presets from one machine to another.
  • The node connection type (straight lines or right-angled lines) is now serialized to the project file.
  • Updated the OSC settings dialog. “Sender Port” renamed to “Send Port” and “Port:” renamed to “Recv Port:”.
  • Root nodes can no longer be grouped.
  • Renamed the “Artnet/OSC” tab in Project->Settings to “Protocols” as it now includes TUIO options.
  • Updated the Plain Effector node to grey out “Scale Y” and “Scale Z” parameters when the “Uniform Scale” parameter is selected.
  • Renamed a Particle Root node’s “Fixed Update Framerate” parameter to “Fixed Update Rate” so that you can wire it up by dragging a node’s output onto the property view.
  • Renamed the “Frame Rate” parameter in a Video Loader node to “Framerate” to match the envelope name.
  • Renamed the “Velocity Scale” envelope to “Velocity Amount” to match parameter name in the Particle Field Affector node.
  • Updated Expression Modifier node to remove newlines from expressions.
  • Updated the Nodes: Colour Ramp node so the “Num Control Points” parameter slider is clamped from 1-16. We only support 16 colours at present but the slider used to go to 20.
  • Updated the Nodes: Layer Precomp node so that toggling “Preview In Viewport” disables “Preview Alpha In Viewport” and vice versa.
  • Updated the Generate Normal Map node to use the same texture format as its input texture.
  • Updated the Vector Blur node so the “Steps”, “Step Size”, “Gradient Blur Iterations” and Epsilon parameters are now envelopes, so they can be animated.
  • Updated the “Focus On Selected” button so it works with non-orbit scene cameras.
  • Updated the Feedback node so that the Feedback parameters are now keyable.
  • Updated the Volumetric Lighting node so it now renders out an alpha channel.
  • Updated the Perception Neuron node to validate the IP address that is entered before attempting to connect.
  • Changed default brightness of light nodes, including area lights from 2.0 to 1.0.
  • Updated the Bins Browser window so that you can open and close folders.
  • Updated light nodes so that the affected/excluded object inputs affect shadow casting too.
  • Updated the Environment Map node so it now uses the layer’s background colour when no inputs are connected.
  • Updated texture resources in the Resource Browser so they report the correct type based on a number of encoded component formats.
  • Updated the Material node to replace the Parallax Mapping checkbox with a Parallax Amount slider, which allows parallax mapping to be used independently of vertex displacement.
  • Removed Transform properties from a Group node. Groups should just do grouping.
  • Updated the Nodegraph to make sure you cannot link a node to itself as input.
  • Updated Median Filter Post-FX node so that “Num Iterations” is now an envelope.
  • Moved the “OSC Text String” node from Modifiers group to the “Nodes” group.
  • Updated the Particle Geometry Connection Renderer to allow it to be transformed.
  • Updated Video nodes to fix a floating point rounding issue when calculating the frame index.
  • Changed the default heading of the Orbit camera to 45 degrees so it aligns with the grid.
  • Changed the layout of parameters in a number of nodes, for example, Material.
  • Updated the Fisheye Camera and VR 360 Camera nodes to allow a max cube resolution of 4096 instead of 2048.
  • Updated the Combine Geometry node so it now works with the Procedural Meshing node.
  • Updated the Procedural Particles As Primitives node so individual emitters can now be plugged in as well as particle roots.
  • Updated the Procedural Melt node so it now supports coloured procedurals.
  • Updated the Procedural Particles node so individual emitters can now be plugged in as well as Particle Root nodes.
  • Updated the Property Editor to not merge group exposed properties.
  • Updated Cloners to allow Execute Child nodes and Select Child nodes to select the cloned geometry.
  • Updated the Particle Image Emitter node to allow any video node to be used as a velocity buffer.
  • Updated the Render to Texture node to allow it to use motion buffers.
  • Updated to use Visual Studio 2015 Update 3 redistributables, as required by RealSense.
  • Updated to use Visual Studio 2013 Update 5 redistributables.
  • Updated to use the new D3D shader compiler, D3DCompiler_47.dll.
  • Improved the performance of the run-time shader compiler process, which should help with building scenes with procedural nodes.

Bug fixes

  • Fixed the Avi video loader to correctly calculate the FPS of an imported video.
  • Fixed the “Active” parameter on the Frame Buffer node so that it now works.
  • Fixed a bug in the Layer Precomp node, which meant the layer precomp was not rendering at the specified resolution in some edge cases.
  • Updated the image sequence import dialog, which was incorrectly referring to CSV files.
  • Fixed the C4D file importer to correctly detect an animated camera’s FOV value.
  • Fixed a number of bugs in our DXT compression and HAPQ rendering that made the renders bias to blue and look bad in the darks.
  • Fixed text-related bugs on the splash screen when GUI scaling was set to more than 100%.
  • Fixed a bug in the Timeline window relating to dragging layers bars off the edge of the screen.
  • Fixed the “Show Metrics” parameter on the Procedural Meshing node so the text is not huge and cropped off the edge of the screen.
  • Fixed a number of possible crashes when traversing circular dependencies in the Nodegraph.
  • Fixed the “Radius” and “Outer Radius” parameters on a Turbulence Affector node so they now work.
  • Fixed the Particle Mesh Emitter node so that it works correctly when the Particle Root node is transformed.
  • Fixed a bug in the Probe Lighting node with respect to seams in the octahedral mapping.
  • Fixed bugs related to motion vectors for skinned FBX objects.
  • Fixed rendering issues in the Nodegraph when replacing nodes via the context menu. For example, replacing a Comment node with a Particle Root node caused the Particle Root node to render using a tiny icon.
  • Fixed a bug in the Field Shadows node which would cause rendering artifacts if the field was non-square.
  • Fixed a bug which meant scene cameras in group nodes would not be selectable when pressing the 6,7,8,9 shortcut keys.
  • Fixed a bug when saving presets to filenames containing a slash character.
  • Fixed a bug when instancing bins that could cause parameters values to be incorrectly set.
  • Fixed a bug where a parameter’s min and max values could be interpreted as radians not degrees.
  • Fixed a bug enabling and disabling nodes via the property view visibility tick box when remote network editing blocks.
  • Removed an unnecessary right-click context menu option in Connection Monitor window.
  • Fixed a bug in the Wavefront loader where separate meshes were not being combined by material, which resulted in hundreds of meshes for an object.
  • Fixed issues with alpha and UV image inputs not being picked up in the Composite Image node.
  • Fixed the Ctrl+D shortcut so that it no longer interferes with the current clipboard items.
  • Fixed a bug in the anti-aliasing support so that TXAA and offline renders using FSAA can work together.
  • Fixed issues with disabled buttons in the GUI not rendering correctly.
  • Fixed a bug where imported TGA textures were upside down. We now read the TGA file header and flip accordingly.
  • Fixed a number of bugs relating to loading resources from UNC and network paths.
  • Fixed a crash in the Curve Editor when deleting curves or switching projects.
  • Fixed a bug copying keys in the Curve Editor when they have the same time value.
  • Fixed a crash bug when selecting files from the recent files list available from the File menu.
  • Fixed the Particle Primitive Collision Affector node so it works with Particle Event nodes.
  • Fixed a bug in the Screen-Space Reflections node. Reflections had black edges at the fade-out regions whenever an environment map was being used.
  • Fixed an OptiTrack bug relating to skeletons being detected as invalid when they were not.
  • Fixed the Transform Image node’s “Rotation” parameter which was previously confusing degrees and radians.
  • Fixed a node ordering bug in the node tree where nodes would appear out of order.
  • Fixed the Ruler where time marks were slightly offset from keys and bars.
  • Fixed a bug in the Property window relating to remembering scroll positions by node type.
  • Fixed the Text node so that plugging a Kill Box Effector node into it now works.
  • Fixed the Depth Camera / Kinect Mesh node to set the vertex alpha to 1.0 instead of 0.5.
  • Fixed the rendering of object lines so they work with UV Camera nodes.
  • Fixed a bug in the Spline node, which was not correctly handling transforms loaded from C4D files.
  • Fixed a bug in the Composite Image node where the transformation manipulator movement was inverted.
  • Fixed the grid artifacts which occurred in the Procedural Particles As Primitives Blobs mode.
  • Fixed a bug in the video export path relating to HAP renders.
  • Fixed the OSC transport command for setting the time. The value passed in did not represent seconds correctly.
  • Fixed a bug in the Transform Array node which broke blob tracking inputs.
  • Fixed a bug in the Shape 3D node where the Rounded Cylinder shape type had incorrect polygons on the top part meaning it was not always as flat as it should be.
  • Fixed a bug in the export video dialog with regards to the AVI2 export option not being remembered.
  • Fixed a bug in the Image 2D node where the image would be skewed if rotated.
  • Fixed the Volumetric Lighting node so that it works with high resolution renders.
  • Fixed tab ordering in a lot of dialogs throughout.
  • Fixed an issue with picking that meant sometimes it would not turn off once you had picked a node.
  • Fixed failure to output JPEG image sequences. This was due to the quality setting being above 100 which caused the JPEG compressor to fail.
  • Fixed a bug in the Particle Trail Renderer node which meant the lines were transformed twice.
  • Fixed the exposed DMX view so that multichannel properties now show the use of multiple slots.
  • Fixed a number of bugs relating to the “Uniform Scale” parameter on Effector nodes.
  • Fixed a crash when CSV files had the “Reflect Resource Changes” option enabled and the CSV file was updated.
  • Fixed the Dot Matrix node so that it works with the alpha channel. Previously when applied to alpha it was outputting squares rather than circles.
  • Fixed an issue in our Javascript support relating to global time not being correctly set.
  • Fixed a crash when importing an FBX file with no UVs.
  • Fixed a bug where the “Export Audio” tickbox on the export video dialog would be disabled when loading from a preset using a codec that does support audio.
  • Fixed a rounding error in the Expression Parser node.
  • Fixed a bug in the Procedural Primitive node which caused the Torus mode to have an incorrect in-editor bounding box.
  • Fixed a bug in the Value As Tex: node. There was a limit (lower than standard float limit) on how large the converted value could be, and it was possible to cause a crash when changing the separator string property.
  • Fixed a bug which meant gamma correction was not being accounted for correctly in the Nodes: Image2D node.
  • Fixed a bug in the Face Tracker node, which meant the “Face Found” property would not be set correctly when the “Low Latency” parameter was ticked.
  • Fixed Curve Mask and Freehand Mask nodes to display in the aspect ratio of the image currently being previewed in the viewport.
  • Fixed a bug resetting the Root node properties so it no longer clears the Creators property.
  • Fixed a bug in the Screen Space Reflections node where the maximum sample count was raised to 256, but Poisson samples buffer size was still 64. Both are now 256.
  • Fixed a bug in the Volumetric Lighting node which meant a white square could appear in the top-left of the viewport.
  • Fixed a bug loading Alembic files that are marked as offline in the Resource Browser.
  • Fixed a bug when importing .hdr files which could cause Builder to hang.
  • Fixed a bug in the Feedback Blur node which meant it would not apply the effect to any layer other than the root.
  • Fixed the TXAA Post-FX node so that it works with render layers and Render to Texture nodes.
  • Fixed some bugs in general file handling where paths above 260 characters long would cause issues.
  • Fixed issues viewing manual pages for multiple selected nodes in the node tree.
  • Fixed a crash when deselecting nodes using Ctrl in the Timeline window.
  • Fixed a crash when resetting node properties for some nodes.
  • Fixed a UV indexing issue related to Alembic files.
  • Fixed animation playback of Alembic files with animated topologies.
  • Fixed bugs loading Alembic files with per-vertex UVs.
  • Fixed a bug where Alembic files may not have been loaded in auto recovered projects.
  • Fixed a bug where the “Do not embed resource” option was not being honoured for Alembic files.
  • Fixed issues with duplicating nodes in the Nodegraph creating extra nodes hidden behind each other.
  • Fixed a bug where resetting node properties or transforms would not update layer precomps.
  • Fixed a bug in the Nodegraph where a Layer Precomp node did not correctly render the name of the layer it was referring to.
  • Fixed the Radial Blur node’s “Active” parameter so that it works when connected as a child of a video node.
  • Fixed a bug when tessellating the Shape 3D node’s rounded cylinder shape type.
  • Fixed the word and letter spacing in the Text node so you can scale the point size and the relative spacing does not change.
  • Fixed the Volumetric Lighting node so that it works with the Multi Camera node.
  • Fixed undo support so that layer precomps that need updating will be updated.
  • Fixed a bug in the Procedural Generator Image node’s Heightmap mode which meant changes to the wrapping modes did not have any effect until the node was re-enabled.
  • Fixed bugs with slice orientations when moving into the field, or when using Multi Camera nodes alongside the Field Renderer node.
  • Fixed a bug in the Procedural Particles node where the particles effect would completely fail if the bounding box became too large.
  • Fixed the Triggerable Envelope Modifier node to make it reset properly.
  • Fixed the Material node’s “Smoothing Angle” parameter so it now works.